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1 OVERVIEW 

The DHS Geospatial Management Office (GMO) upgraded their geospatial platform in order to take 

advantage of the new capabilities offered in ArcGIS 10.3.1 for Desktop, Portal, and Server. The robust 

portal and server capabilities are listed below. 

Portal 10.3.1 

 Monitor usage statistics using Activity Dashboard for ArcGIS 

 Create applications using Web AppBuilder for ArcGIS 

 Support for publishing very large numbers of feature services to portal (ArcGIS Data Store) 

 You can drag layers in the Contents pane to change their order 

 Authors can add text symbols to their map when using map notes layers with the Map Notes 

ArcGIS for Server 10.3.1 

 Ability to Share secured ArcGIS services in Portal for ArcGIS or ArcGIS for Desktop 

 Ability to Share 3D content using Scene services 

 Ability to Customize the behavior of map and image services to execute custom logic 

ArcGIS Server provides a proprietary token-based authentication mechanism where users or applications 

can authenticate themselves by providing a token instead of a user name and password. ArcGIS for Server 

token-based authentication supports sharing secured ArcGIS for Server services in Portal for ArcGIS. 

This new feature will allow HSIN users to utilize secured ArcGIS for Server services in Portal for ArcGIS 

or ArcGIS for Desktop.  

ArcGIS for Server provides an easy to use web-based token generation application, which works 

seamlessly with Portal for ArcGIS. The following opportunities will be available: 

 HSIN users will have Portal for ArcGIS  access to ArcGIS for Server services via single sign-on 

 HSIN users will have ArcGIS for Desktop access to ArcGIS for Server services via single sign-on 

 HSIN users will have Esri Maps for Office access to services via single sign-on 

 GMO will be able to apply privileges down to the service level for ArcGIS for Server services 

 ArcGIS for Server tokens are tied to specific domains 

1.1 Scope 

The guide covers the following capabilities in ArcGIS 10.3.1 for Desktop and Portal:  

 Create a Web Map 

o This functionality is replacing OneView  

 Add HIFLD Open data to a Map 

 Gain access to GII Portal services in the ArcGIS Desktop client (ArcMap)  

 Publish GIS data from ArcGIS Desktop (ArcMap) to the GII Portal  

o Specify data accessibility/sharing status 

 Create a web application from an existing map that is hosted and shared within GII Portal 
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1.2 Prerequisites 

The following prerequisites must be in place in order for a user to successfully access or perform the 

different GII Portal capabilities: 

All Users: 

 Must have an active HSIN user account 

Accessing GII Services from desktop: 

 Must have a licensed ArcGIS Desktop application properly installed 

Creating Web Application: 

 Must have a saved map within GII Portal 

1.3 HSIN Terms of  Service 

Each HSIN user is expected to follow the HSIN Terms of Service, which covers rules of behavior, 

privacy, and many other responsibilities. Use this link to review the Terms of Service.  

Note: You must be logged into HSIN in order to view this document. 

 

  

https://hsin.dhs.gov/Governance/Policies/HSIN_Governance_Policy/TOS_Outline.docx
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2 CREATE A WEB MAP 

The following instructions explain how to create a map in the GII and add HIFLD Open data layers to it. 

 
Go to: https://gii.dhs.gov/gii   
Select Map from the top menu of the GII Portal 

 
 
Search for the area or map extent 

https://gii.dhs.gov/gii
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Select a basemap 
 

 
Add data layers to your map by selecting Add 
Note: You can search for a data layer on the GII Portal, add a layer from the web, add a layer from a file, 
or add map notes 
 

 
Select to search for a layer from the web 
For HSIP or HIFLD data, use the default data reference – an ArcGIS Server Web Service 
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Add the URL Example for Railroads: 
https://services2.arcgis.com/1cdV1mIckpAyI7Wo/arcgis/rest/services/Railroads/FeatureServer/0  
Refer to Add HIFLD Open Data to a Map for more information on how to get the HIFLD data layer URL. 
 

 
Save your map when you are done 
 
 

 
You can find your map under My Content from the main GII menu 
  

https://services2.arcgis.com/1cdV1mIckpAyI7Wo/arcgis/rest/services/Railroads/FeatureServer/0


 

  

GII Portal 10.3.x User Guide   8 

3 ADD HIFLD OPEN DATA TO A MAP 

This section will explain how to find HIFLD Open data layers and add them to your web map using GII 

Portal. 

Note: Homeland Infrastructure Foundation Level Data (HIFLD) layers are replacing the data layers 

known as HSIP. 

Go to HIFLD Open: https://gii.dhs.gov/hifld/data/open  

 

 
Scroll down the home page of HIFLD Open in order to explore the categories 

https://gii.dhs.gov/hifld/data/open
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Select Energy, for example 

 

 
Scroll through the list and select the data layer of interest  
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Once you are on the home page of this data layer, right-click source 

Select “Copy link address” (Chrome), “Copy Link Location” (Firefox), or “Copy shortcut” (Internet 

Explorer) in order to copy the URL 

 

In the GII Portal for your map, select: 

Add 
Select to search for a layer from the web 

 
For HSIP or HIFLD data, use the default data reference – an ArcGIS Server Web Service 
Add the URL  

For Example, add Natural Gas Market Hubs: 

https://services2.arcgis.com/1cdV1mIckpAyI7Wo/arcgis/rest/services/Natural_Gas_Market_Hubs/Featur

eServer/0  

 

 

 
 

  

https://services2.arcgis.com/1cdV1mIckpAyI7Wo/arcgis/rest/services/Natural_Gas_Market_Hubs/FeatureServer/0
https://services2.arcgis.com/1cdV1mIckpAyI7Wo/arcgis/rest/services/Natural_Gas_Market_Hubs/FeatureServer/0
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4 ACCESSING GII PORTAL SERVICES (FROM ARCMAP) 
To connect from your ArcGIS Desktop to Portal for ArcGIS, you must first enter the connection using 

ArcGIS Administrator.  Please close out any ArcGIS Catalog or ArcMap sessions before setting up the 

GII Portal connection. 

1) Open ArcGIS Administrator (typically found in the ArcGIS folder in your programs and files, 

START – All Programs – ArcGIS Folder – ArcGIS Administrator) and click Advanced… 
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2) In the Advanced Configuration choose Manage Portal Connections… 

 

3) Manage ArcGIS Portal Connections will display a list of your current connections 

4) Choose Add to enter a new connection   

 

5) Enter the URL to the ArcGIS Portal and Click OK. 
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6) Once added, you can select a connection and choose Connect: 

 

7) Once your portal connection has been set, the Manage Portal and ArcGIS Connections will 

disappear and you will be back to the Advanced Configuration dialog.  Select Save at the bottom 

of the dialog to complete the GII Portal connection.  You can sign in from ArcMap  

8) Click File, then “Sign In” to access your portal items, groups and services. 

 

9) Follow the HSIN Login prompts in order to authenticate your user account.  Users can use either 

their DHS PIV card or their HSIN User Name and Password and second factor code. 
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10) To add web maps and/or feature layers from GII Portal click File > Add Data > Add Data from 

Portal for ArcGIS 
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11) GII web services will appear.  Users can select Add to add GII web services to their current 

ArcMap session.  

 

 

 

5 PUBLISHING GIS DATA TO PORTAL (FROM ARCMAP) 
HSIN users have multiple ways of publishing data to the GII Portal.  Users publish data to the GII Portal 

to share their geospatial products to a Portal Group or Groups or to the entire GII enterprise for 

communication and collaboration purposes supporting situational awareness missions.   

Users will need to be Signed in to the GII before sharing map packages or publishing hosted feature 

services.  The steps for all of these capabilities are described below. 

5.1 Share Map Packages 

Map Packages: Map packages (.mpk) include a map document (.mxd) and the data referenced by the map 

layers packaged into one portable file. Like a layer package, a map package make it easy to share maps 

that include the symbology of the source map between colleagues in a work group, across departments in 

an organization, or with other partner agencies. Map packages also allow the ability to create an archive 

of a particular map that contains a snapshot of the current state of the data used in the map.  

For example, if a group wants certain symbology to persist on a map, a map package can be shared, so the 

symbology persists. 

1) Open the map you want to share. 

2) Click File > Share As > Map Package. 
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3) Choose Upload package to my account. 

 

4) Type name for the map package. 

a. At a minimum, you must provide a summary and tags for the Item Description. You can 

also provide the Description, Access and Use Constraints, and Credits for the map 

package. 

5) Click Sharing and indicate whether the map package should be shared with specific groups or 

with everyone in your organization. 

6) Click Share to create the map package and add it as an item to your portal. 

5.2 Publish Hosted Features 

The following steps explain how to publish hosted features. 

Note: ArcGIS Online layers and Portal for ArcGIS layers are added to ArcMap as ArcGIS feature 

services. ArcGIS feature services are unsupported in map services and must be removed from the 

ArcMap table of contents before attempting to publish. 

1) Open the map you wish to share. 
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2) Click File > Share As > Service. 

3) Select Publish a service and click Next> 
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4) Highlight My Hosted Services (GII) from Choose a connection dropdown. 

5) Type name for the service being created and click Continue. 

a. Item Description > At a minimum, you must provide a summary and tags for the Item 

Description. You can also provide the Description, Access and Use Constraints, and 

Credits for the map package. 
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b. Sharing > Select the organizational groups that the service will be shared with 

6) Click Publish 

*Before services attempts to publish it analyzes data to ensure data integrity, if any errors are found it 

may require them to be resolved before completing publishing task. 

6 REGISTER A SERVICE FROM A PARTNER PORTAL IN THE GII 

The following steps explain how to register an Esri secure service from a partner portal in the GII Portal. 

You need to know the service URL and the username/password for the service. Make sure that this 

service has been shared with the appropriate GII group. 

Steps: 

1. In the GII Portal, go to My Content 

2. Click Add Item, From the web 
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3. The Item from the Web Pop-Up will appear 

 

4. Use the default type – ArcGIS Service Web Service 

5. Add the URL 

6. Once Portal detects that a secure service has been added, you will be prompted for the username 

and password 

 

7. Select Store credentials with service item. Do not prompt for authentication. 

8. Add a title and tags 

9. Click Add Item 

10. The service is now registered for use in the GII Portal 
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7 CREATE APPS FROM MAPS 

You can create an app with a shared map by using a configurable app template. Different templates and 

Web AppBuilder offer various functionality, such as different layouts and color schemes, editing and 

identify tools, social media feeds, and side-by-side map viewers. Once you have found a template you 

like configure the components and publish the app.  

*A published web app is based on a map authored with the map viewer. Any changes the author makes to 

the map, including its extent, layers, description, and so on, are reflected in the web app. If a map that 

was available to everyone in the organization is made private (or deleted), the map no longer appears in 

the app. 

7.1 Sharing Map 

1) Verify that you are signed in with privileges to create and share content. 

2) Open a saved map in the map viewer and click Share. You can only make an app with a map that 

is shared. If you own the map, share it by specifying sharing options in the Share window. If you 

don't own the map, contact the owner and have them share it as necessary. 

7.2 Make a Web Application 

The following steps explain how to make a web application. 

Note: An HTTP 404 error is returned when creating an application from Portal for ArcGIS 10.3.1 My 

Content page using a template. Create the application from the map viewer following the procedure below 

instead of the My Content page. 

1) From Share pop-up click Make a Web Application. 
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2) Select the tab of which application you would like to build (Configurable App or 

Web_AppBuilder) 
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7.2.1 Configurable App 

1) Click the Configurable Apps tab. 
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2) Hover over and click a template thumbnail to see a description of the template.

 

3) Click Publish > Publish to start configuring your app. 

4) Type a title, tags, and summary for your app and choose the folder in which to save the app. 

5) If you want to immediately share this app, click Share this app in the same way as the map. If you 

do not check this, you’ll need to specify how to share the app from My Content. 

 

6) Click Save & Publish to publish the app 
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7) Change the components of the app you want, such as the theme, widgets, and miscellaneous 

items. Click Save when you are done configuring the app. 

7.2.2 Web AppBuilder 

1) Click the Web App Builder tab and click the GET STARTED button below: 

a. Type a title, tags, and summary for your app. 

b. Choose in which folder the app should be saved. 

c. Choose whether to apply the same sharing properties to the app as you have on the map. 

 
 

 

2) Select Themes 

a. Create a custom Style color in banner 

b. Layout (where widget will be placed in the viewer): 
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3) Select Map 

a. Choose Web Map 

b. Set Initial Extent and customize visible scales 
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4) Select Widgets – Widgets gives application functionality. 

 

5) Configure Attributes – customize your application banner with logo, title and hyperlinks 

 

 

6) Preview – preview the application 

7) Save and Launch – Web Mapping Application created in My Content area. 
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8 CREATE A STORY MAP 

The steps in this section explain how to create a story map. These steps are very similar to the steps for 

creating a Web App. 

8.1 Share Your Map 

1) Verify that you are signed in with privileges to create and share content. 

2) Open a saved map in the map viewer and click Share. You can only make an app with a map that 

is shared. If you own the map, share it by specifying sharing options in the Share window. If you 

don't own the map, contact the owner and have them share it as necessary. 

8.2 Choose a Story Map Template 

The following steps explain how to create a Story Map. 

Note: An HTTP 404 error is returned when creating an application from Portal for ArcGIS 10.3.1 using 

My Content page for the template. Create the application from the map viewer following the procedure 

below instead of using My Content page. 

1) From Share pop-up click Make a Web Application. 

a. Note: If you have a private group, select only that group.  

i. Do not select Everyone or GII. If you select either of those two groups, you will 

be sharing your Story Map with either anyone who can access the URL or 

anyone who can login with their HSIN ID. 
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2) Select the tab of which application you would like to build  

3) Use Configurable App in order to access the Story Map templates. [Located on page 3] 

4) Hover over the Story Map to get a description of the template 

 

5) Select the Publish dropdown and Select Preview to view the template 

 

6) Select Publish to create the Story Map 

 

7) Enter Information on the Make a Web Application Form 
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8) Select Save and Publish 

9) Choose the configuration options for the Story Map template 

10) The Story Map Builder will appear, so you can complete your Story Map 

8.3 Story Map Information 

There are links on the preview page of the Story Map Journal template for a Tutorial, Build a Hosted 

App, Download a configurable app, FAQs, and Blog posts 

 

11) You can also download the source code from Gatha and update it  

8.4 Story Map Templates 

The following sections contain examples of the Story Map templates. 

8.4.1 Story Map Journal 
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8.4.2 Story Map Series 

 
 

  



 

  

GII Portal 10.3.x User Guide   32 

8.4.3 Storytelling Basic 

This Story Map contains the Title, Description, and Legend for your map. 
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8.4.4 Storytelling Swipe 

Compare two layers of a map with a swipe. 

Note: Select the Switch to Builder mode to update settings. 

 

The following Story Map is in Builder Mode. 
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8.4.4.1 Configuring Swipe 

The following screens show how to configure swipe as a vertical bar for one layer. 

 

Choose vertical bar or spyglass 

 

Select the layer to swipe [turn on/off] 

Or choose between 2 different layers 

 

Choose Configuration settings 
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Choose the Header for the Pop-up 


